Tuesday , 24 May 2022
Breaking News

Cisco NAT Configuration Troubleshooting

Spread the love

Cisco NAT Configuration Troubleshooting

Lab – Troubleshooting NAT Configurations

  • Topology
  • Addressing Table

Cisco NAT Configuration Troubleshooting

Device Interface IP Address Subnet Mask Default Gateway
Gateway G0/1 192.168.1.1 255.255.255.0 N/A
  S0/0/1 209.165.200.225 255.255.255.252 N/A
ISP S0/0/0 (DCE) 209.165.200.226 255.255.255.252 N/A
  Lo0 198.133.219.1 255.255.255.255 N/A
PC-A NIC 192.168.1.3 255.255.255.0 192.168.1.1
PC-B NIC 192.168.1.4 255.255.255.0 192.168.1.1

Objectives

Part 1: Build the Network and Configure Basic Device Settings

Part 2: Troubleshoot Static NAT

Part 3: Troubleshoot Dynamic NAT

  • Background / Scenario

In this lab, we will discuss Cisco NAT Configuration Troubleshooting. The Gateway router was configured by an inexperienced network administrator at your company.

Several errors in the Cisco NAT Configuration Troubleshooting have resulted in NAT issues. Your boss has asked you to troubleshoot and correct the NAT errors and document your work. Ensure that the network supports the following:

How to Configure Port Address Translation (PAT)

  • PC-A acts as a web server with a static NAT and will be reachable from the outside using the 165.200.254 address.
  • PC-B acts as a host computer and dynamically receives an IP address from the created pool of addresses called NAT_POOL, which uses the 209.165.200.240/29 range.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other routers, switches and Cisco IOS versions can be used.

Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Make sure that the routers and switch have been erased and have no startup configurations. If you are unsure, contact your instructor.

How to Configure Dynamic and Static NAT

  • Required Resources
  • 2 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • 1 Switch (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
  • 2 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and serial cables as shown in the topology
  • Build the Network and Configure Basic Device Settings

In Part 1, you will set up the network topology and configure the routers with basic settings. Additional Cisco NAT Configuration Troubleshooting is provided. The NAT configurations for the Gateway router contain errors that you will identify and correct as you proceed through the lab.

  • Cable the network as shown in the topology.
  • Configure PC hosts.
  • Initialize and reload the switch and routers.
  • Configure basic settings for each router.
    1. Console into the router and enter global configuration mode.
    2. Copy the following basic configuration and paste it to the running configuration on the router.

no ip domain-lookup

service password-encryption

enable secret class

banner motd #

Unauthorized access is strictly prohibited. #

line con 0

password cisco

login

logging synchronous

line vty 0 4

password cisco

login

  1. Configure the hostname as shown in the topology.
  2. Copy the running configuration to the startup configuration.
  • Configure static routing.

    1. Create a static route from the ISP router to the Gateway router which was assigned public network address range 209.165.200.224/27.

ISP(config)# ip route 209.165.200.224 255.255.255.224 s0/0/0

  1. Create a default route from the Gateway router to the ISP router.

Gateway(config)# ip route 0.0.0.0 0.0.0.0 s0/0/1

  • Load router configurations.

The configurations for the routers are provided for you. There are errors with the configuration for the Gateway router. Identify and correct the configuration errors.

Gateway Router Configuration

interface g0/1

ip nat outside

no shutdown

interface s0/0/0

ip nat outside

interface s0/0/1

no shutdown

ip nat inside source static 192.168.2.3 209.165.200.254

ip nat pool NAT_POOL 209.165.200.241 209.165.200.246 netmask 255.255.255.248

ip nat inside source list NAT_ACL pool NAT POOL

ip access-list standard NAT_ACL

permit 192.168.10.0 0.0.0.255

banner motd $AUTHORIZED ACCESS ONLY$

end

  • Save the running configuration to the startup configuration.
  • Troubleshoot Static NAT

In Part 2, you will examine the static NAT for PC-A to determine if it is configured correctly. You will troubleshoot the scenario until the correct static NAT is verified.

  1. To troubleshoot issues with NAT, use the debug ip nat Turn on NAT debugging to see translations in real-time across the Gateway router.

Gateway# debug ip nat

  1. From PC-A, ping Lo0 on the ISP router. Does any NAT debug translations appear on the Gateway router?

____________________________________________________________________________________

  1. On the Gateway router, enter the command that allows you to see all current NAT translations on the Gateway router. Write the command in the space below.

____________________________________________________________________________________

Why are you seeing a NAT translation in the table, but none occurred when PC-A pinged the ISP loopback interface? What is needed to correct the issue?

____________________________________________________________________________________

  1. Record any commands that are necessary to correct the static NAT configuration error.

____________________________________________________________________________________

 

  1. From PC-A, ping Lo0 on the ISP router. Does any NAT debug translations appear on the Gateway router?

____________________________________________________________________________________

  1. On the Gateway router, enter the command that allows you to observe the total number of current NATs. Write the command in the space below.

____________________________________________________________________________________

Is the static NAT occurring successfully? Why?

____________________________________________________________________________________

  1. On the Gateway router, enter the command that allows you to view the current configuration of the router. Write the command in the space below.

____________________________________________________________________________________

  1. Are there any problems with the current configuration that prevents the static NAT from occurring?

____________________________________________________________________________________

  1. Record any commands that are necessary to correct the static NAT configuration errors.

____________________________________________________________________________________

  1. From PC-A, ping Lo0 on the ISP router. Does any NAT debug translations appear on the Gateway router?

____________________________________________________________________________________

  1. Use the show ip nat translations verbose command to verify static NAT functionality.

Note: The timeout value for ICMP is very short. If you do not see all the translations in the output, redo the ping.

Is the static NAT translation occurring successfully? ____________________

If static NAT is not occurring, repeat the steps above to troubleshoot the configuration.

  • Troubleshoot Dynamic NAT
    1. From PC-B, ping Lo0 on the ISP router. Does any NAT debug translations appear on the Gateway router?

________________

  1. On the Gateway router, enter the command that allows you to view the current configuration of the router. Are there any problems with the current configuration that prevent dynamic NAT from occurring?

How to Configure Basic DHCPv4 on a Router

____________________________________________________________________________________

  1. Record any commands that are necessary to correct the dynamic NAT configuration errors.

____________________________________________________________________________________

  1. From PC-B, ping Lo0 on the ISP router. Does any NAT debug translations appear on the Gateway router?

____________________________________________________________________________________

  1. Use the show ip nat statistics to view NAT usage.

Is the NAT occurring successfully? _______________

What percentage of dynamic addresses has been allocated? __________

  1. Turn off all debugging using the undebug all
  • Reflection

    1. What is the benefit of a static NAT?

_______________________________________________________________________________________

_______________________________________________________________________________________

  1. What issues would arise if 10 host computers in this network were attempting simultaneous Internet communication?

_______________________________________________________________________________________

  • Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class.

This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device.

The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface.

The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Leave a Reply

Your email address will not be published.

Adnan Online Class
%d bloggers like this: