Tuesday , 24 May 2022
Breaking News

Configuring Basic Switch Setting with Commands and Examples

Spread the love
  • Addressing Table
Device Interface IP Address Subnet Mask Default Gateway
S1 VLAN 99 192.168.1.2 255.255.255.0 192.168.1.1
PC-A NIC 192.168.1.10 255.255.255.0 192.168.1.1
  • Objectives

basic switch setting

Part 1: Cable the Network and Verify the Default Switch Configuration

Part 2: Configure Basic Network Device Settings

  • Configure basic switch settings.
  • Configure the PC IP address.

Part 3: Verify and Test Network Connectivity

  • Display device configuration.
  • Test end-to-end connectivity with ping.
  • Test remote management capabilities with Telnet.
  • Save the switch running configuration file.

Part 4: Manage the MAC Address Table

  • Record the MAC address of the host.
  • Determine the MAC addresses that the switch has learned.
  • List the show mac-address-table command options.
  • Set up a static MAC address.
  • Background / Scenario

Cisco switches can be configured with a special IP address known as the switch virtual interface (SVI). The SVI, or management address, can be used for remote access to the switch to display or configure settings. If the VLAN 1 SVI is assigned an IP address, by default all ports in VLAN 1 have access to the SVI IP address.

In this lab, you will build a simple topology using Ethernet LAN cabling and access a Cisco switch using the console and remote access methods. You will examine default switch configurations before configuring basic switch settings. These basic switch settings include device name, interface description, local passwords, message of the day (MOTD) banner, IP addressing, and static MAC address.

You will also demonstrate the use of a management IP address for remote switch management. The topology consists of one switch and one host using only Ethernet and console ports.

Note: The switch used is a Cisco Catalyst 2960 with Cisco IOS Release 15.0(2) (lanbasek9 image). Other switches and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in this lab.

Note: Make sure that the switch has been erased and has no startup configuration. Refer to Appendix A for the procedures to initialize and reload a switch.

  • Required Resources
  • 1 Switch (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
  • 1 PC (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term, and Telnet capability)
  • 1 Console cable to configure the Cisco IOS device via the console port
  • 1 Ethernet cable as shown in the topology
  • Cable the Network and Verify the Default Switch Configuration

In Part 1, you will set up the network topology and verify default switch settings.

  • Cable the network as shown in the topology.
    1. Connect the console cable as shown in the topology. Do not connect the PC-A Ethernet cable at this time.

Note: If you are using Netlab, shut down F0/6 on S1. This has the same effect as not connecting PC-A to S1.

  1. Connect to the switch from PC-A using Tera Term or other terminal emulation program.

Why must you use a console connection to initially configure the switch? Why is it not possible to connect to the switch via Telnet or SSH?

____________________________________________________________________________________

  • Verify the default switch configuration.

In this step, you will examine the default switch settings, such as current switch configuration, IOS information, interface properties, VLAN information, and flash memory.

You can access all the switch IOS commands in privileged EXEC mode. Access to privileged EXEC mode should be restricted by password protection to prevent unauthorized use because it provides direct access to global configuration mode and commands used to configure operating parameters. You will set passwords later in this lab.

The privileged EXEC mode command set includes those commands contained in user EXEC mode, as well as the configure command through which access to the remaining command modes is gained. Use the enable command to enter privileged EXEC mode.

  1. Assuming the switch had no configuration file stored in nonvolatile random-access memory (NVRAM), A console connection using Tera Term or other terminal emulation program will place you at the user EXEC mode prompt on the switch with a prompt of Switch>. Use the enable command to enter privileged EXEC mode.

Switch> enable

Switch#

Notice that the prompt changed in the configuration to reflect privileged EXEC mode.

Verify that there is a clean default configuration file on the switch by issuing the show running-config privileged EXEC mode command. If a configuration file was previously saved, it must be removed. Depending on the switch model and IOS version, your configuration may look slightly different. However, there should be no configured passwords or IP address. If your switch does not have a default configuration, erase and reload the switch.

Note: Appendix A details the steps to initialize and reload a switch.

  1. Examine the current running configuration file.

Switch# show running-config

How many FastEthernet interfaces does a 2960 switch have? ________

How many Gigabit Ethernet interfaces does a 2960 switch have? ________

What is the range of values shown for the vty lines? ________

  1. Examine the startup configuration file in NVRAM.

Switch# show startup-config

startup-config is not present

Why does this message appear? _________________________________________________________

  1. Examine the characteristics of the SVI for VLAN 1.

Switch# show interface vlan1

Is there an IP address assigned to VLAN 1? ________

What is the MAC address of this SVI? Answers will vary. ______________________________________

Is this interface up?

____________________________________________________________________________________

  1. Examine the IP properties of the SVI VLAN 1.

Switch# show ip interface vlan1

What output do you see?

____________________________________________________________________________________

____________________________________________________________________________________

  1. Connect an Ethernet cable from PC-A to port 6 on the switch and examine the IP properties of the SVI VLAN 1. Allow time for the switch and PC to negotiate duplex and speed parameters.

Note: If you are using Netlab, enable interface F0/6 on S1.

Switch# show ip interface vlan1

What output do you see?

____________________________________________________________________________________

____________________________________________________________________________________

  1. Examine the Cisco IOS version information of the switch.

Switch# show version

What is the Cisco IOS version that the switch is running? ______________________________________

What is the system image filename? ______________________________________________________

What is the base MAC address of this switch? Answers will vary. _________________________________

  1. Examine the default properties of the FastEthernet interface used by PC-A.

Switch# show interface f0/6

Is the interface up or down? _____________________

What event would make an interface go up? ________________________________________________

What is the MAC address of the interface? ___________________________

What is the speed and duplex setting of the interface? ______________________

  1. Examine the default VLAN settings of the switch.

Switch# show VLAN

What is the default name of VLAN 1? ____________

Which ports are in VLAN 1? ___________________________________________________________

Is VLAN 1 active? ____________

What type of VLAN is the default VLAN? _______________ Examine flash memory.

Issue one of the following commands to examine the contents of the flash directory.

Switch# show flash

Switch# dir flash:

Files have a file extension, such as .bin, at the end of the filename. Directories do not have a file extension.

What is the filename of the Cisco IOS image? ______________________________________________

  • Configure Basic Network Device Settings

In Part 2, you will configure basic settings for the switch and PC.

  • Configure basic switch settings.

    1. Copy the following basic configuration and paste it into S1 while in global configuration mode.

no ip domain-lookup

hostname S1

service password-encryption

enable secret class

banner motd #

Unauthorized access is strictly prohibited. #

Line con 0

password cisco

login

logging synchronous

line vty 0 15

password cisco

login

exit

  1. Set the SVI IP address of the switch. This allows remote management of the switch.

Before you can manage S1 remotely from PC-A, you must assign the switch an IP address. The default configuration on the switch is to have the management of the switch controlled through VLAN 1. However, a best practice for basic switch configuration is to change the management VLAN to a VLAN other than VLAN 1.

For management purposes, use VLAN 99. The selection of VLAN 99 is arbitrary and in no way implies that you should always use VLAN 99.

First, create the new VLAN 99 on the switch. Then set the IP address of the switch to 192.168.1.2 with a subnet mask of 255.255.255.0 on the internal virtual interface VLAN 99.

S1# configure terminal

S1(config)# vlan 99

S1(config-vlan)# exit

S1(config)# interface vlan99

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to down

S1(config-if)# ip address 192.168.1.2 255.255.255.0

S1(config-if)# no shutdown

S1(config-if)# exit

S1(config)#

Notice that the VLAN 99 interface is in the down state even though you entered the no shutdown command. The interface is currently down because no switch ports are assigned to VLAN 99.

  1. Assign all user ports to VLAN 99.

S1(config)# interface range f0/1 – 24,g0/1 – 2

S1(config-if-range)# switchport access vlan 99

S1(config-if-range)# exit

S1(config)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up

To establish connectivity between the host and the switch, the ports used by the host must be in the same VLAN as the switch. Notice in the above output that the VLAN 1 interface goes down because none of the ports are assigned to VLAN 1. After a few seconds, VLAN 99 comes up because at least one active port (F0/6 with PC-A attached) is now assigned to VLAN 99.

  1. Issue the show VLAN brief command to verify that all ports are in VLAN 99.

S1# show VLAN brief

 

VLAN Name                             Status    Ports

—- ——————————– ——— ——————————-

1    default                          active

99   VLAN0099                         active    Fa0/1, Fa0/2, Fa0/3, Fa0/4

Fa0/5, Fa0/6, Fa0/7, Fa0/8

Fa0/9, Fa0/10, Fa0/11, Fa0/12

Fa0/13, Fa0/14, Fa0/15, Fa0/16

Fa0/17, Fa0/18, Fa0/19, Fa0/20

Fa0/21, Fa0/22, Fa0/23, Fa0/24

Gi0/1, Gi0/2

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

  1. Configure the default gateway for S1. If no default gateway is set, the switch cannot be managed from a remote network that is more than one router away. Although this activity does not include an external IP gateway, assume that you will eventually connect the LAN to a router for external access. Assuming that the LAN interface on the router is 192.168.1.1, set the default gateway for the switch.

S1(config)# ip default-gateway 192.168.1.1

S1(config)#

  1. Console port access should also be restricted. The default configuration is to allow all console connections with no password needed. To prevent console messages from interrupting commands, use the logging synchronous

S1(config)# line con 0

S1(config-line)# password cisco

S1(config-line)# login

S1(config-line)# logging synchronous

S1(config-line)# exit

S1(config)#

  1. Configure the virtual terminal (vty) lines for the switch to allow Telnet access. If you do not configure a vty password, you will not be able to Telnet to the switch.

S1(config)# line vty 0 15

S1(config-line)# password cisco

S1(config-line)# login

S1(config-line)# end

S1#

*Mar  1 00:06:11.590: %SYS-5-CONFIG_I: Configured from console by console

Why is the login command required? _________________________________________________

  • Configure an IP address on PC-A.

Assign the IP address and subnet mask to the PC as shown in the Addressing Table. An abbreviated version of the procedure is described here. A default gateway is not required for this topology; however, you can enter 192.168.1.1 to simulate a router attached to S1.

  • Click the Windows Start icon > Control Panel.
  • Click View By: and choose Small icons.
  • Choose Network and Sharing Center > Change adapter settings.
  • Select Local Area Network Connection, right-click and choose Properties.
  • Choose Internet Protocol Version 4 (TCP/IPv4) > Properties.
  • Click the Use the following IP address radio button and enter the IP address and subnet mask.
  • Verify and Test Network Connectivity

In Part 3, you will verify and document the switch configuration, test end-to-end connectivity between PC-A and S1, and test the switch’s remote management capability.

  • Display the switch configuration.

Use the console connection on PC-A to display and verify the switch configuration. The show run command displays the entire running configuration, one page at a time. Use the spacebar to advance paging.

  1. A sample configuration is shown here. The settings you configured are highlighted in yellow. The other configuration settings are IOS defaults.

S1# show run

Building configuration…

 

Current configuration: 2206 bytes

!

version 15.0

no service pad

service timestamps debug DateTime msec

service timestamps log DateTime msec

service password-encryption

!

hostname S1

!

boot-start-marker

boot-end-marker

!

enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2

!

no aaa new-model

system mtu routing 1500

!

!

no ip domain-lookup

!

<output omitted>

!

interface FastEthernet0/24

switchport access vlan 99

!

interface GigabitEthernet0/1

switchport access vlan 99

!

interface GigabitEthernet0/2

switchport access vlan 99

!

interface Vlan1

no ip address

no ip route-cache

!

interface Vlan99

ip address 192.168.1.2 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.1

ip http server

ip http secure-server

!

banner motd ^C

Unauthorized access is strictly prohibited. ^C

!

line con 0

password 7 104D000A0618

logging synchronous

login

line vty 0 4

password 7 14141B180F0B

login

line vty 5 15

password 7 14141B180F0B

login

!

end

 

S1#

  1. Verify the management VLAN 99 settings.

S1# show interface vlan 99

Vlan99 is up, line protocol is up

Hardware is EtherSVI, address is 0cd9.96e2.3d41 (bia 0cd9.96e2.3d41)

Internet address is 192.168.1.2/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:06, output 00:08:45, output hang never

Last clearing of “show interface” counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

175 packets input, 22989 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

1 packets output, 64 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

What is the bandwidth on this interface? ________________

What is the VLAN 99 state? _________

What is the line protocol state? _________

  • Test end-to-end connectivity with ping.
    1. From the command prompt on PC-A, ping the address of PC-A first.

C:\Users\User1> ping 192.168.1.10

  1. From the command prompt on PC-A, ping the SVI management address of S1.

C:\Users\User1> ping 192.168.1.2

Because PC-A needs to resolve the MAC address of S1 through ARP, the first packet may time out. If ping results continue to be unsuccessful, troubleshoot the basic device configurations. Check both the physical cabling and logical addressing.

  • Test and verify remote management of S1.

You will now use Telnet to remotely access the switch. In this lab, PC-A and S1 reside side by side. In a production network, the switch could be in a wiring closet on the top floor while your management PC is located on the ground floor. In this step, you will use Telnet to remotely access switch S1 using its SVI management address.

Telnet is not a secure protocol; however, you will use it to test remote access. With Telnet, all information, including passwords and commands, are sent across the session in plain text. In subsequent labs, you will use SSH to remotely access network devices.

Note: If you are using Windows 7, the administrator may need to enable the Telnet protocol. To install the Telnet client, open a command window and type pkgmgr /iu:“TelnetClient”. An example is shown below.

C:\Users\User1> pkgmgr /iu:”TelnetClient”

  1. With the command window still open on PC-A, issue a Telnet command to connect to S1 via the SVI management address. The password is cisco.

C:\Users\User1> telnet 192.168.1.2

  1. After entering the password cisco, you will be at the user EXEC mode prompt. Access privileged EXEC mode using the enable command and providing the secret password class.
  2. Type exit to end the Telnet session.
  • Save the switch running configuration file.

Save the configuration.

S1# copy running-config startup-config

Destination filename [startup-config]? [Enter]

Building configuration…

[OK]

S1#

  • Manage the MAC Address Table

In Part 4, you will determine the MAC addresses that the switch has learned, set up a static MAC address on one interface of the switch, and then remove the static MAC address from that interface.

  • Record the MAC address of the host.

Open a command prompt on PC-A and issue the ipconfig /all command to determine and record the Layer 2 (physical) addresses of the NIC.

_______________________________________________________________________________________

  • Determine the MAC addresses that the switch has learned.

Display the MAC addresses using the show mac-address-table command.

S1# show mac-address-table

How many dynamic addresses are there? ____________

How many MAC addresses are there in total? ____________

Does the dynamic MAC address match the MAC address of PC-A? ____________

  • List the show mac address-table options.
    1. Display the MAC address table options.

S1# show mac-address-table?

How many options are available for the show mac address-table command? ____________

  1. Issue the show mac-address-table dynamic command to display only the MAC addresses that were learned dynamically.

S1# show mac address-table dynamic

How many dynamic addresses are there? ____________

  1. View the MAC address entry for PC-A. The MAC address formatting for the command is xxxx.xxxx.xxxx.

S1# show mac-address-table address <PC-A MAC here>

  • Set up a static MAC address.
    1. Clear the MAC address table.

To remove the existing MAC addresses, use the clear mac-address-table dynamic command in privileged EXEC mode.

S1# clear mac address-table dynamic

  1. Verify that the MAC address table was cleared.

S1# show mac-address-table

How many static MAC addresses are there? ________________________________________________

How many dynamic addresses are there? __________________________________________________

  1. Examine the MAC table again.

More than likely, an application running on your PC has already sent a frame out the NIC to S1. Look at the MAC address table again in privileged EXEC mode to see if S1 has relearned the MAC address of PC-A.

S1# show mac-address-table

How many dynamic addresses are there? _________

Why did this change from the last display? _________________________________________________

If S1 has not yet relearned the MAC address for PC-A, ping the VLAN 99 IP address of the switch from PC-A, and then repeat the show mac-address-table command.

  1. Set up a static MAC address.

To specify which ports a host can connect to, one option is to create a static mapping of the host MAC address to a port.

Set up a static MAC address on F0/6 using the address that was recorded for PC-A in Part 4, Step 1. The MAC address 0050.56BE.6C89 is used as an example only. You must use the MAC address of PC-A, which is different from the one given here as an example.

S1(config)# mac address-table static 0050.56BE.6C89 vlan 99 interface fastethernet 0/6

  1. Verify the MAC address table entries.

S1# show mac-address-table

How many total MAC addresses are there? __________

How many static addresses are there? _____________

  1. Remove the static MAC entry. Enter global configuration mode and remove the command by putting a no in front of the command string.

Note: The MAC address 0050.56BE.6C89 is used in the example only. Use the MAC address for PC-A.

S1(config)# no mac address-table static 0050.56BE.6C89 vlan 99 interface FastEthernet 0/6

  1. Verify that the static MAC address has been cleared.

S1# show mac-address-table

How many total static MAC addresses are there? ____________

  • Reflection
    1. Why should you configure the vty password for the switch?

_______________________________________________________________________________________

  1. Why change the default VLAN 1 to a different VLAN number?

_______________________________________________________________________________________

  1. How can you prevent passwords from being sent in plain text?

_______________________________________________________________________________________

  1. Why configure a static MAC address on a port interface?

_______________________________________________________________________________________

  • Appendix A: Initializing and Reloading a Switch
    1. Console into the switch and enter privileged EXEC mode.

Switch> enable

Switch#

  1. Use the show flash command to determine if any VLANs have been created on the switch.

Switch# show flash

Directory of flash:/

 

2  -rwx        1919   Mar 1 1993 00:06:33 +00:00  private-config.text

3  -rwx        1632   Mar 1 1993 00:06:33 +00:00  config.text

4  -rwx       13336   Mar 1 1993 00:06:33 +00:00  multiple-fs

5  -rwx    11607161   Mar 1 1993 02:37:06 +00:00  c2960-lanbasek9-mz.150-2.SE.bin

6  -rwx         616   Mar 1 1993 00:07:13 +00:00  vlan.dat

 

32514048 bytes total (20886528 bytes free)

Switch#

  1. If the dat file was found in flash, then delete this file.

Switch# delete vlan.dat

Delete filename [vlan.dat]?

  1. You are prompted to verify the filename. If you have entered the name correctly, press Enter; otherwise, you can change the filename.
  2. You are prompted to confirm the deletion of this file. Press Enter to confirm.

Delete flash:/vlan.dat? [confirm]

Switch#

  1. Use the erase startup-config command to erase the startup configuration file from NVRAM. You are prompted to remove the configuration file. Press Enter to confirm.

Switch# erase startup-config

Erasing the NVRAM filesystem will remove all configuration files! Continue? [confirm] [OK]

Erase of NVRAM: complete

Switch#

  1. Reload the switch to remove any old configuration information from memory. You will then receive a prompt to confirm the reloading of the switch. Press Enter to proceed.

Switch# reload

Proceed with reload? [confirm]

Note: You may receive a prompt to save the running configuration prior to reloading the switch. Respond by typing no and pressing Enter.

System configuration has been modified. Save? [yes/no]: no

  1. After the switch reloads, you should see a prompt to enter the initial configuration dialogue. Respond by entering no at the prompt and pressing Enter.

Would you like to enter the initial configuration dialog? [yes/no]: no

Switch>

Leave a Reply

Your email address will not be published.

Adnan Online Class
%d bloggers like this: