Tuesday , 24 May 2022
Breaking News

How to Configure Basic DHCPv4 on a Router

Spread the love

How to Configure Basic DHCPv4 on a Router

Lab – Configuring Basic DHCPv4 on a Router

  • Topology
  • Addressing Table
How to Configure Basic DHCPv4 on a Router
How to Configure Basic DHCPv4 on a Router.
Device Interface IP Address Subnet Mask Default Gateway
R1 G0/0 192.168.0.1 255.255.255.0 N/A
G0/1 192.168.1.1 255.255.255.0 N/A
S0/0/0 (DCE) 192.168.2.253 255.255.255.252 N/A
R2 S0/0/0 192.168.2.254 255.255.255.252 N/A
S0/0/1 (DCE) 209.165.200.226 255.255.255.224 N/A
ISP S0/0/1 209.165.200.225 255.255.255.224 N/A
PC-A NIC DHCP DHCP DHCP
PC-B NIC DHCP DHCP DHCP
  • Objectives

Part 1: Build the Network and Configure Basic Device Settings

Part 2: Configure a DHCPv4 Server and a DHCP Relay Agent

  • Background / Scenario

How to Configure Basic DHCPv4 on a Router. This article will help to teach that the Dynamic Host Configuration Protocol (DHCP) is a network protocol that lets network administrators manage and automate the assignment of IP addresses. Without DHCP, the administrator must manually assign and configure IP addresses, preferred DNS servers, and default gateways. As the network grows in size, this becomes an administrative problem when devices are moved from one internal network to another.

How to Configure and Verifying Standard IPv4 ACLs

In this scenario, the company has grown in size, and the network administrators can no longer assign IP addresses to devices manually. Your job is to configure the R2 router to assign IPv4 addresses on two different subnets connected to router R1.

Note: This lab provides minimal assistance with the actual commands necessary to configure DHCP. However, the required commands are provided in Appendix A. Test your knowledge by trying to configure the devices without referring to the appendix.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other routers, switches and Cisco IOS versions can be used.

Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Make sure that the routers and switches have been erased and have no startup configurations. If you are unsure, contact your instructor.

  • Required Resources
  • 3 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • 2 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
  • 2 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and serial cables as shown in the topology
  • Build the Network and Configure Basic Device Settings

In Part 1, you will set up the network topology and configure the routers and switches with basic settings, such as passwords and IP addresses. You will also configure the IP settings for the PCs in the topology.

  • Cable the network as shown in the topology.
  • Initialize and reload the routers and switches.
  • Configure basic settings for each router.
    1. Console into the router and enter global configuration mode.
    2. Copy the following basic configuration and paste it to the running-configuration on the router.

How to Configure Basic DHCPv4 on a Router

no ip domain-lookup

service password-encryption

enable secret class

banner motd #

Unauthorized access is strictly prohibited. #

line con 0

password cisco

login

logging synchronous

line vty 0 4

password cisco

login

  1. Configure the host name as shown in the topology.
  2. Configure the IPv4 addresses on the router as shown in the topology.
  3. Set the DCE serial interfaces with a clock rate of 128000.
  • Configure dynamic, default, and static routing on the routers.
    1. Configure RIPv2 for R1.

R1(config)# router rip

R1(config-router)# version 2

R1(config-router)# network 192.168.0.0

R1(config-router)# network 192.168.1.0

R1(config-router)# network 192.168.2.252

R1(config-router)# no auto-summary

  1. Configure RIPv2 and a default route to the ISP on R2.

R2(config)# router rip

R1(config-router)# version 2

R2(config-router)# network 192.168.2.252

R2(config-router)# default-information originate

R2(config-router)# exit

R2(config)# ip route 0.0.0.0 0.0.0.0 209.165.200.225

  1. Configure a summary static route on ISP to reach the networks on the R1 and R2 routers.

ISP(config)# ip route 192.168.0.0 255.255.252.0 209.165.200.226

  1. Copy the running configuration to the startup configuration.
  • Verify network connectivity between the routers.

If any pings between routers fail, correct the errors before proceeding to the next step. Use show ip route and show ip interface brief to locate possible issues.

  • Verify the host PCs are configured for DHCP.
  • Configure a DHCPv4 Server and a DHCP Relay Agent

To automatically assign address information on the network, you will configure R2 as a DHCPv4 server and R1 as a DHCP relay agent.

  • Configure DHCPv4 server settings on router R2.

On R2, you will configure a DHCP address pool for each of the R1 LANs. Use the pool name R1G0 for the G0/0 LAN and R1G1 for the G0/1 LAN. You will also configure the addresses to be excluded from the address pools. Best practice dictates that excluded addresses be configured first, to guarantee that they are not accidentally leased to other devices.

Exclude the first 9 addresses in each R1 LAN starting with .1. All other addresses should be available in the DHCP address pool. Make sure that each DHCP address pool includes a default gateway, the domain ccna-lab.com, a DNS server (209.165.200.225), and a lease time of 2 days.

On the lines below, write the commands necessary for configuring DHCP services on router R2, including the DHCP-excluded addresses and the DHCP address pools.

Note: The required commands for Part 2 are provided in Appendix A. Test your knowledge by trying to configure DHCP on R1 and R2 without referring to the appendix.

____________________________________________________________________________________

____________________________________________________________________________________

 

On PC-A or PC-B, open a command prompt and enter the ipconfig /all command. Did either of the host PCs receive an IP address from the DHCP server? Why?

____________________________________________________________________________________

  • Configure R1 as a DHCP relay agent.

Configure IP helper addresses on R1 to forward all DHCP requests to the R2 DHCP server.

On the lines below, write the commands necessary to configure R1 as a DHCP relay agent for the R1 LANs.

_______________________________________________________________________________________

_______________________________________________________________________________________

 

  • Record IP settings for PC-A and PC-B.

On PC-A and PC-B, issue the ipconfig /all command to verify that the PCs have received IP address information from the DHCP server on R2. Record the IP and MAC address for each PC.

_______________________________________________________________________________________

Based on the DHCP pool that was configured on R2, what are the first available IP addresses that PC-A and PC-B can lease?

_______________________________________________________________________________________

  • Verify DHCP services and address leases on R2.

    1. On R2, enter the show ip dhcp binding command to view DHCP address leases.

Along with the IP addresses that were leased, what other piece of useful client identification information is in the output?

__________________________________________________________________________________

  1. On R2, enter the show ip dhcp server statistics command to view the DHCP pool statistics and message activity.

How many types of DHCP messages are listed in the output?

____________________________________________________________________________________

  1. On R2, enter the show ip dhcp pool command to view the DHCP pool settings.

In the output of the show ip dhcp pool command, what does the current index refer to?

____________________________________________________________________________________

  1. On R2, enter the show run | section dhcp command to view the DHCP configuration in the running configuration.
  2. On R1, enter the show run interface command for interfaces G0/0 and G0/1 to view the DHCP relay configuration in the running configuration.
  • Reflection

What do you think is the benefit of using DHCP relay agents instead of multiple routers acting as DHCP servers?

_______________________________________________________________________________________

_______________________________________________________________________________________

 

  • Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has.

There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device.

The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

  • Appendix A – DHCP Configuration Commands
  • Router R1

R1(config)# interface g0/0

R1(config-if)# ip helper-address 192.168.2.254

R1(config-if)# exit

R1(config-if)# interface g0/1

R1(config-if)# ip helper-address 192.168.2.254

  • Router R2

R2(config)# ip dhcp excluded-address 192.168.0.1 192.168.0.9

R2(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9

R2(config)# ip dhcp pool R1G1

R2(dhcp-config)# network 192.168.1.0 255.255.255.0

R2(dhcp-config)# default-router 192.168.1.1

R2(dhcp-config)# dns-server 209.165.200.225

R2(dhcp-config)# domain-name ccna-lab.com

R2(dhcp-config)# lease 2

R2(dhcp-config)# exit

R2(config)# ip dhcp pool R1G0

R2(dhcp-config)# network 192.168.0.0 255.255.255.0

R2(dhcp-config)# default-router 192.168.0.1

R2(dhcp-config)# dns-server 209.165.200.225

R2(dhcp-config)# domain-name ccna-lab.com

R2(dhcp-config)# lease 2

Leave a Reply

Your email address will not be published.

Adnan Online Class
%d bloggers like this: